FAQ FAQ  Forum Search   Register Register  Login Login

Inconsistent Frametimes on insane Aventum X

Post Date: 2021-02-12

 Post Reply Post Reply
Author
  Topic Search Topic Search  Topic Options Topic Options
IATMG View Drop Down
Newbie
Newbie


Joined: 12 Feb 2021
Online Status: Offline
Posts: 2
  Quote IATMG Quote  Post ReplyReply bullet Topic: Inconsistent Frametimes on insane Aventum X
    Posted: 12 Feb 2021 at 6:32pm
I just got this PC of my dreams and while I've been going through a variety of games, I've been noticing near-constant stutters during gameplay.

My TV is 60hz/1080p (I've usually do native res, but have played with 200% supersampling), so I usually try to vsync at 60fps so that it will be silky smooth. My prior rig (3570k/970/16GB/SSD) never had frame timing issues and I could usually get a steady 60FPS out of it just modifying the graphics settings. Yeah, I know... "why 1080p?" I'll be upgrading the TV soon, but I'd like to think that if I supersample to [email protected] (which most games barely hit on Ultra), then 60FPS should be no issue and there should be no overflow.

However, on this build (specs below), almost like a heartbeat, it'll drop 10-15 frames. If I turn vsync off, the framerate usually doubles/triples but it still has the rhythmic*-ish* drop in frames (even though it's still over 100FPS or whatever). It's just that, at that high of a framerate, it's no longer smooth, hence my preference for 60 vsync.

There should be zero bottlenecks on this rig, but the drops happen no matter the settings. So, I've been researching - I've:

- Clean installed the video drivers

- Verified the memory (via windows memory test) is OK

- Verified the 520's are OK (NVMes)

- Played with video settings and even switched to low; still stutter.

- Tried RTSS. With RTSS, I found that games crash if I have the overlay on at all (crashed constantly anyway until I used the current beta due to the Windows update bug). So, really, I just have the FPS cap at 60 and have found that it performs *slightly* better with the Direct3D support off. However, the frametime graph from afterburner looks like an EKG! (albeit with longer flat periods between the beats) As an aside, an interesting vsync issue I found is that if you have global settings set to 60 as well, you'll get visual tearing in the game, even at 60FPS, with vsync on (I guess it's because the game is also doing this). Anyway, RTSS seems to not be the magic cure. And why would it even be needed, honestly? It shouldn't be needed.

This… is frustrating! The system is able to put out 200-300 fps with Ultra settings for a lot of games… so a SOLID 60FPS shouldn't be an issue!

For instance, I opened up Deep Rock Galactic last night, set all settings to Ultra. vsync off? *Literally* 500FPS! vsync on? 40-50FPS constant stutter. And that's just in the small loading home base area! WTF?

Whatever the current version of Windows 10 Pro is, is what I'm on.

I've toggled Windows Game Mode on or off - makes zero difference in-game.

I've toggled MSI's Dragon Center performance options, they make no difference. Even played with their Game Boost (including OFF), none of the settings make a discernible difference, so it's off.

Any frame drops are like knives into what remains of my eyes, so any suggestions that I haven't found yet or things you've done to fix it would be greatly appreciated! Thank you for your time if you've made it this far!

[UserBenchmarks: Game 242%, Desk 108%, Work 292%]
MSI Godlike X570
5950x
3090
3600Mhz RAM CAS 14 (verified running at that speed)
NVME drive that tests at 4.9GB/s
Liquid cooled

I've also:
- limited global frame rate settings to 60fps via Nvidia CP - that seemed to help some!
It still randomly drops some frames, but it's not as bad? Seems to ping between 58-60 a lot - I read on another website that it should actually be set to 2-3 frames below your refresh rate -- which kind of makes sense since when you turn it on, its default is 58. I'll have to play with that later. --- Edit: that made it worse lol.

- Updated Bios from 1C5 to 1C6 (latest)

- Disabled full screen optimizations. Advanced graphics settings doesn't exist on my install, so I did the regedit.

However, I played some BFV with the 60 limit and it still does the stutter at first... like a lot. Then as you play the level it smooths out with just maybe once a minute split second freezes/stutters. It's almost like it's gotta cache something first.

- Turned off game mode, dragon center on startup, other apps that have 'high impact'.

- Completely uninstalled/reinstalled Nvidia drivers.


Edited by IATMG - 12 Feb 2021 at 6:33pm
Back to Top
IATMG View Drop Down
Newbie
Newbie


Joined: 12 Feb 2021
Online Status: Offline
Posts: 2
  Quote IATMG Quote  Post ReplyReply bullet Posted: 12 Feb 2021 at 7:42pm
I did some more testing and using GPUZ I get the following when I'm capped at 60FPS via the PerfCap option:

vRel
VOp

At 30FPS Nvidia cap, it's just vRel (it still stutters at 30, just not as obvious).

I have an EVGA 1600w Plat power supply. The framerate/time drops seem to coincide with those spikes in GPUZ for those errors.

Checked around and heard they are normal, but this is what they mean:

vRel = Reliability. Indicating perf is limited by reliability voltage.

VOp = Operating. Indicating perf is limited by max operating voltage.

Does this mean I have a bad GPU?
Back to Top
Snaike View Drop Down
Moderator Group
Moderator Group

Just a dude trying to keep the spam away
Email address used to purchase matched with forums account email.

Joined: 23 Jan 2014
Online Status: Offline
Posts: 8495
  Quote Snaike Quote  Post ReplyReply bullet Posted: 12 Feb 2021 at 11:36pm
Contact DS support in the morning. One of the tech guys is hanging around these forums and has offered his direct email address for support. [email protected] might be a good resource as well.

Hope you get it sorted!
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down



This page was generated in 3.515625E-02 seconds.